Правильный 6to4 на MikroTik

Прикупил я тут себе по случаю Микротик 951G-2HnD.
Решил что хватит быть писюку шлюзом и хватит отдельно иметь точку доступа для wifi и пора бы всё это перевесить на одну более-менее управляемую железку.
Захотелось иметь 6to4 на обычном белом IPv4, но не тут-то было.
Создал туннель 6to4 с local-address моим белым ipv4, но без remote-address (6to4 работает именно так, иначе связность 2002::/16 теряется), повесил адрес на этот интерфейс, но вот добавить маршрут 2000::/3 (он же ::/0) хоть и получается, но трафик туда не ходит.
Штош. Добавил remote-address в туннель – и вуяля – у меня стали доступны адреса ipv6, но потерялась связность со всеми 2002::/16 адресами, что для меня не подходит чуть более чем полностью.
Пришлось сделать два туннеля – один для 6to4-адресов 2002::/16, второй для всего остального.
Микротик такой микротик.

А теперь для сильных духом коротко и по делу:
/ipv6 address
add address=2002:5eXX:XXXX::/128 advertise=no interface=6to4-native
add address=2002:5eXX:XXXX:400::1/64 interface=bridge1
add address=2002:5eXX:XXXX::1/16 advertise=no interface=6to4-tunnel
/ipv6 route
add distance=1 gateway=6to4-native,2002:c058:6301::1
add distance=1 dst-address=2002::/16 gateway=6to4-tunnel
add distance=1 dst-address=2002:c058:6301::1/128 gateway=6to4-native
/interface 6to4
add !keepalive local-address=94.45.X.X name=6to4-native remote-address=192.88.99.1
add !keepalive local-address=94.45.X.X name=6to4-tunnel

И для работы 6to4 не забыть разрешить в фаерволе от в4 в input протокол 41.

Комментарии | опубликовано: Фев 19, 03:58

IPv4 over IPv6

Есть контора selectel.ru, которая предоставляет облачные серверы. У меня там VDS-ка, используемая для dns. Сервисом доволен, на тикеты реакция моментальная, в месяц выходит меньше 100 рублей.
Они собираются с 17 января брать плату за IPv4-адрес порядка 70р в месяц, а адреса IPv6 раздавать бесплатно. У меня всё готово к v6-only, кроме репликации mysql. Я решил сделать туннель IPv4 через IPv6 исключительно для репликации mysql, котороый по в6 репликацию пока не умеет. В гугле всречается в основном IPv6 over IPv4, нам же надо наоборот. Пришлось читать документацию :)

Создаём туннель на стороне сервера с мускуль-мастером:
/sbin/ip -6 tunnel add ns2s6 mode ip4ip6 local 2001:db8:100::1 remote 2001:db8:200:2
/sbin/ip link set ns2s6 up
/sbin/ip addr add 172.18.1.1/30 dev ns2s6

Создаём туннель на вдс-ке:
/sbin/ip -6 tunnel add ns2s6 mode ip4ip6 local 2001:db8:200::2 remote 2001:db8:100:1
/sbin/ip link set ns2s6 up
/sbin/ip addr add 172.18.1.2/30 dev ns2s6

Проверяем пингом оба конца туннеля, удостоверяемся что он работает, в мускуле правим IP слейва и IP мастера, радуемся.

Комментарии | опубликовано: Янв 12, 20:33

<--- Предыдущая страница