Правильный 6to4 на MikroTik

Прикупил я тут себе по случаю Микротик 951G-2HnD.
Решил что хватит быть писюку шлюзом и хватит отдельно иметь точку доступа для wifi и пора бы всё это перевесить на одну более-менее управляемую железку.
Захотелось иметь 6to4 на обычном белом IPv4, но не тут-то было.
Создал туннель 6to4 с local-address моим белым ipv4, но без remote-address (6to4 работает именно так, иначе связность 2002::/16 теряется), повесил адрес на этот интерфейс, но вот добавить маршрут 2000::/3 (он же ::/0) хоть и получается, но трафик туда не ходит.
Штош. Добавил remote-address в туннель – и вуяля – у меня стали доступны адреса ipv6, но потерялась связность со всеми 2002::/16 адресами, что для меня не подходит чуть более чем полностью.
Пришлось сделать два туннеля – один для 6to4-адресов 2002::/16, второй для всего остального.
Микротик такой микротик.

А теперь для сильных духом коротко и по делу:
/ipv6 address
add address=2002:5eXX:XXXX::/128 advertise=no interface=6to4-native
add address=2002:5eXX:XXXX:400::1/64 interface=bridge1
add address=2002:5eXX:XXXX::1/16 advertise=no interface=6to4-tunnel
/ipv6 route
add distance=1 gateway=6to4-native,2002:c058:6301::1
add distance=1 dst-address=2002::/16 gateway=6to4-tunnel
add distance=1 dst-address=2002:c058:6301::1/128 gateway=6to4-native
/interface 6to4
add !keepalive local-address=94.45.X.X name=6to4-native remote-address=192.88.99.1
add !keepalive local-address=94.45.X.X name=6to4-tunnel

И для работы 6to4 не забыть разрешить в фаерволе от в4 в input протокол 41.

Комментарии | опубликовано: Фев 19, 03:58

Полная очистка arp-кеша в linux

Задался я тут вопросом как реально почистить arp-кеш в linux. В принципе он меня не парит, но arp -n | grep выполняется около 35 секунд, что несколько дохрена. Решение нашёл.
Куча сайтов советуют arp -d <IP> <iface>, но это не работает т.к. остаётся запись с incomplete (а у меня их было почти 70 тысяч).
Другая куча советует сделать ip -s neigh flush all, но это по прежнему не работает по тем же причинам.
А вот как на самом деле реально удалить вообще все arp-записи для интерфейса:
ip link set arp off dev eth0; ip link set arp on dev eth0
В моей ситуации, когда надо удалить все записи incomplete из arp я написал нехитрый однострочник:
arp -n | grep incomplete | awk '{ print $3 }' | sort | uniq | awk '{ system("ip link set arp off dev "$1"; ip link set arp on dev "$1) }'

Комментарии | опубликовано: Фев 21, 21:54

<--- Предыдущая страница